服务器暂时无法处理您的请求,请稍后再试,解决方案

放大字体  缩小字体 发布日期:2022-03-31  来源:免费学习网  责任编辑:爱学  浏览次数:42
核心提示:[正文]商城最近在支付成功后跳转的页面出现弹层报错,经排查是百度地图的js导致,有以下2种方法修改第一:修改 addons/ewei_shop
 [正文]商城最近在支付成功后跳转的页面出现弹层报错,经排查是百度地图的js导致,有以下2种方法修改
 
第一:修改 addons/ewei_shopv2/static/js/app/biz/store/selector.js 中 https://api.map.baidu.com/getscript 为 https://api.map.baidu.com/api
第二:修改 addons/ewei_shopv2/static/js/myconfig-app.js 中 urlArgs: ‘v=’ + version 将 v= 修改为 t=
原因分析:
百度地图应该最近修改过 https://api.map.baidu.com/getscript 的获取逻辑,在 https://api.map.baidu.com/getscript 后面会跟上参数版本号 v=2.0 形成 https://api.map.baidu.com/getscript?v=2.0(省略了其他参数)
 
由于require的配置文件中有 urlArgs 参数会在链接后面加上v,值是一个时间戳,导致链接变成 https://api.map.baidu.com/getscript?v=2.0&v=1743516779730
 
此链接一打开就能看到其中有 服务器暂时无法处理您的请求,请稍后重试
 
百度地图接收是后面的v,以前百度地图但实际并没有拿v来获取对应版本,但现在处理了,所以找不到对应的版本,就有这个提示
 
所以方法1是将获取js的换成另外一个(官方有2种),但保不齐https://api.map.baidu.com/api后面也会获取v,所以最佳方法是第二种
 
 
[ 新闻资讯搜索 ]  [ 加入收藏 ]  [ 告诉好友 ]  [ 打印本文 ]  [ 关闭窗口 ]

 

 
推荐图文
推荐新闻资讯
点击排行
 
学习网 | 新闻资讯 | 工作学习 | 行业动态 | RSS订阅 | 滇ICP备13001045号